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1. GENERAL INFORMATION

Dear customer,

thank you very much for choosing our product.

In the following, we will introduce you to what to observe while starting
up and using this product.

Should you encounter any unexpected problems during use, please do



2. PIN ASSIGNMENT OF THE DISPLAY

Pin Designation Pin number

1/0

Function

VSS 1
VDD 2
VO 3
A0 4
JWR 5
/RD 6

3,3-5V

Logic circuit ground

This is a ground pin. It also serves as a reference
for the logic pins. It must be connected to the
external ground.

Power supply for display module circuit
This is a power supply pin.

Voltage supply for OEL panel

This is the most positive voltage supply pin of
the chip.

Please do not connect it.

Data/Command Control

This pin is a data/command control pin. When
the pin is pulled high, the input at D7~DO0 is trea-
ted as display data. When the pin is pulled low,
the input at D7~DO0 is transferred to the com-
mand register.

Read/Write Select or Write

This pin is an MCU interface input. When
connected to a 68XX series microprocessor, this
pin is used as a read/write select (R/W) input.
Pull this pin high for read mode and pull it low
for write mode. When the 80XX interface mode is
selected, this pin is the write input (WR). The da-
ta write operation is initiated when this pin is
pulled "Low" and CS is pulled "Low".

Read/Write Enable or Read

This pin is an MCU interface input. When
connected to a 68XX series microprocessor, this
pin is used as an Enable(E) signal. The read/
write operation is initiated when this pin is pul-
led high and CS is pulled low. When connected
to an 80XX microprocessor, this pin receives the
Read(RD) signal. The data read operation is initi-
ated when this pin is pulled low and CS is pulled
low.



Pin Designation Pin number  1/0 Function

DBO 7 /0
DB1 8 1/O
DB2 9 /0 Host data input/output bus
DB3 10 /0 These pins are bidirectional 8-bit data buses
that connect to the microprocessor data
DB4 11 I/O  bus. When serial mode is selected, D1 is the
DB5 P /0 SDIN serial data input and DO is the SCLK
serial clock input.
DB6 13 1/O
DB7 14 1/0
/CS 15 I Chip-Select
This pin is the chip select input. The chip is
only enabled for MCU communication when
CS#is pulled low.
/RESET 16 [ Power Reset for Controller and Driver
This pin is a reset signal input. When the pin
is low, the initialization of the chip is perfor-
med.
NC (BS1) 17 H/L  Communication protocol selection
NC (BS2) 18 H/L These pins are inputs for selecting the MCU
interface.

See the following table:

68XX- 80XX- 12C Serial
[ETE] parallel

NC 19 - NC or connection to VSS.
FG 20 OV It must be connected to external ground.
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2.1 SETUP OF THE DISPLAY INTERFACE

The display can be controlled in 4 different ways, via 12C, SPI, 8-bit paral-
lel 6800 interface and 8-bit parallel 8080 interface.

The display is delivered pre-configured for control via SPI. If you want to
use one of the other control methods, you have to re-solder the resistors
BS1 and BS2 on the back of the board.

In the table, you can see how the resistors must be set for the respective
mode.

6800-parallel 8080-parallel 12C

|5l

0.

TW28641240A
05

]
|

{
)

i i ([(1({(1 (fJ (Jj ;r“‘

[

c16
(] 5
Lt
<co[ ] [¥T=m] 4 20(0)
.l;_"i aau] [ea) * =

s Ii R20(f)
3 14 Mfr21(0)

LTS ol
3. USE WITH AN ARDUINO

As the display works with a 3V logic level and most Arduinos with 5V, we
use an Arduino Pro Mini 3.3V in this example.

If you want to use an Arduino with a 5V logic level, such as an Arduino
Uno, you have to reduce all data lines leading from the Arduino to the dis-
play from 5V to 3.3V with a logic level converter.

First you need to install the required library in your Arduino IDE.

To do this, go to Tools -> Manage Libraries... Search for u8g2 and install
the library U8g2 by oliver

@ Library Manager

Type |al « | Topic Al + | |usg2]

Usg2

by oliver Version 2.28.10 INSTALLED

Monochrome LCD, OLED and 2Ink Library. Display controller: S5D1205, 5SD1206, SSD1209, SSD1216, SSD1222, S5D1225,
S5D1227, S5D1229, SSD1606, SSD1607, SH1106, SH1107, SH1108, SH1122, T6963, RASS25, LC7981, PCD8544, PCFE812,
HX1220, UC1601, UC1604, UC1608, UC1610, UC1611, UC1617, UC1701, ST7511, ST7528, ST7563, ST7567, ST7571, ST7586,
ST7588, 5T75256, ST75220, NT75324, ST7920, IST2020, IST7920, LD7022, KS0108, KS07132, SED1520, SBN1661, IL2820,
MAX7219. Interfaces: I12C, SPI, Parallel. Monochreme LCD, OLED and elnk Library. Successor of U8glib. Supported display
controller: 5501305, 5501306, 5501309, 5501316, 5501322, 5501325, 5501327, 5501329, 5501606, 5501607, SH1106,
SH1107, SH1108, SH1122, T6963, RABB35, LC7981, PCDE544, PCFE812, HX1230, UC1601, UCis04, UC1i608, UC1610,
UCisli, UC1617, UC1701, ST7511, ST7528, 5T7565, 5T7567,. 5T7571, 5T7586, ST7588, ST75256, ST75320, NT7534,
5T7920, IST3020, IST7920, LD7032, KSO0108, KSO0713, SED1520, SBN1661, IL3820, MAX7219. Supported interfaces: I2C, SPI,
Parallel. Features: UTF8, >700 fonts, UBx8 char output.

Mare info

Select version Instal

UBg2_for_Adafruit_GFX

by oliver Version 1.8.0 INSTALLED
Add U3g2 fonts to any Adafruit GFX based graphics library. Use our favorite Adafruit graphics library together with fonts from
LI8n2 nrniert (httms: A aithoh.ramd alikraons/u8n 2 fwikif/fotlistalll

Close
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SPI-Interface

Now open the GraphicTest code sample of the library.
To do this, click on:
File -> Examples -> U8g2 -> u8x8-> GraphicTest

Now insert the following constructor for the display into the programme,
as shown in the picture below:

USX8_SSD1309 128X64 NONAME2_4W_SW_SPI u8x8(13, 11, 10, 9, 8);

&) GraphicsTest | Arduino 1.8.13 — O X
Datei Bearbeiten Sketch Werkzeuge Hilfe

GraphicsTest§

#include <Arduino.h>
g8 #include «<UBx8lib.h>
3]
30 $ifdef USS_HAVE HW_SPI
41 |#include <SPI.h>
42 #endif
43 #ifdef USXS8_HAVE HW_I2C
44 |#include <Wire.h>

45 |#endif

4c UBXE 55D1309 128X64 NONAMEZ 4W SW SPI usxe (13, 11, 10, 5, 8):

45 f/ Please UNCOMMENT one of the contructor lines below
49 f/ UBx8 Contructor List

50 f/ The complete list is available here: https:/f/github.comfolikraus/ulg2/wiki /uBx8setupcpp

51 f/ Please update the pin numbers according to your setup. Use USXg8_PIN NONE if the reset pin is not v
< >

Arduino Pro or Pro Mini auf CORM11

Now you can upload the example to your Arduino.




12C-Interface

Wiring
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12C-Interface

Now open the GraphicTest code sample of the library.
To do this, click on:
File -> Examples -> U8g2 -> u8x8-> GraphicTest

Now insert the following constructor for the display into the programme,
as shown in the picture below:

USX8_SSD1309 128X64 NONAME2 _HW_I2C u8x8(9, A4, A5);

&) GraphicsTest | Arduing 1.8.13 — O *

Datei Bearbeiten Sketch Werkzeuge Hilfe

GraphicsTest§

xl AUViIiopD b lof PuoodDllLlll e ol UAlkaisr A

44 #include <Arduino.h:>
45 #include <UBx8lib.h>

27 $#ifdef USN8_HAVE HW_SPI
48 #include <SPI.h>

49 |#endif

50 #ifdef USX8_HAVE HW_I2C
51 #include <Wire.h>

52 |#endif

54 UBXE 55D1305 128X64 NONAMEZ HW IZ2C uBxE (5, A4, R3):

55 |// Please UNCOMMENT one of the comtructor lines below

56 |/f U8x8 Contructor List

57 J/ The complete list is available here: https:/fgithub.com/olikraus,/ ulg2/wiki/uix8setupcpp

52 f/ Please update the pin numbers according to yvour setup. Use Ug¥g PIN NONE if the reset pin
col FFTTOWO RITTT T 2aDarl . AT T B B o - DarD wmdarm T A T mrr rrmd sl Aemmm sl e

< >

Arduino Pro or Fro Mini auf COMS

Now you can upload the example to your Arduino.



8 bit Parallel 6800-Interface

Wiring
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8 bit Parallel 6800-Interface

Now open the GraphicTest code sample of the library.
To do this, click on:
File -> Examples -> U8g2 -> u8x8-> GraphicTest

Now insert the following constructor for the display into the programme, as shown
in the picture below:

USX8_SSD1309 128X64 NONAME® 6800 u8x8(13, 11, 2, 3, 4, 5, 6,
A3, 7, 10, 9, 8);

&) GraphicsTest | Arduino 1.8.13 — O ¥
Datei Bearbeiten Sketch Werkzeuge Hilfe

GraphicsTest§

40 $ifdef USXS_HAVE HW_SPI 2
41 #include <SPI.h>

42 #endif

43 $ifdef USX8 HAVE HW_I2C
44 #include <Wire.h>
45 #endif

47 UBX8 S5D1309 128X64 NONAMEO 6800 uSx8(13, 11, 2, 3, 4, 5, 6, A3, 7, 10, 9, 8):
49 f/ Please UNCOMMENT one of the contructor lines below

50 f/ U8xE Contructor List

51 /f The complete list is available here: https://github.com/olikraus/u8g2/wiki/ugxdset

52 f/ Pleasze update the pin numberz according to your setup. Us=e UBXE PIN WONE if the re:
53 |//UBX8_NULL uSx8; // null device, a 8x8 pixel display which does nothing

54 //USX8 S55D1306 128Xe4 NONAME 4W SW_SPI uBxE (/* clock=*/ 13, /* data=*/ 11, /* cs=*/ 1
55 | //UBX8_S55D1306_ 128X64 NCONAME 4W HW _SPI uSxE8(/* cs=*/ &, /* dc=*/ 4, [* reset=*/ 12Z):
//U8Xe S55D1306 128X64 NCOWAME 4W HW SPI u8x8(/* cs=*/ 12, /* dc=*/ 4, /* reset=*/ &):
//UBXE_55D1306_128X64 NCONAME 4W HW SPI udx8(/* cs=*/ 10, /* dc=*/ 9, /* reset=*/ 8): w
£ >

o
1 & in

Arduing Pro ar Pro Mini auf COMS

Now you can upload the example to your Arduino.




8 bit Parallel 8080-Interface

Wiring
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8 bit Parallel 8080-Interface

Now open the GraphicTest code sample of the library.
To do this, click on:
File -> Examples -> U8g2 -> u8x8-> GraphicTest

Now insert the following constructor for the display into the programme,

USX8_SSD1309 128X64 NONAME® 8080 u8x8(13, 11, 2, 3, 4, 5, 6,
A3, 7, 10, 9, 8);

& GraphicsTest | Arduino 1.8.13 — O by
Datei Bearbeiten Sketch Werkzeuge Hilfe

GraphicsTest§

#include <Arduino.h> ~
38 #include <UBxElib.h>

[14]

0 #ifdef USXS_HAVE HW SPI
include <S5PI.h>

endif

ifdef USXE _HAVE HW I2C
44 #¥include <Wire.h>

45 ¥endif
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<7 USX8_S5D1309 128X6€4 NONAMEO 8080 u8x&(13, 11, 2, 3, 4, 5, 6, &3, 7, 10, 9, 8);

I
[¥3]

50 ff Please UHCOMMENT one of the contructor lines below
51 f/ UBxE Contructor List
52 f/ The complete list is available here: https://github.com/olikraus/ufg2/wiki /uExEseti

53 // Please update the pin numbers according to your setup. Use UsXg PIN WONE if the re:
54 //UBXE_NULL u8x8; // null device, a 8x8 pixel display which does nothing W
£ >

Arduino Pro or Pro Mini, ATm ] | MHz) auf COMSE

Now you can upload the example to your Arduino.




4. USE WITH THE RASPBERRY PI

These instructions were written under Raspberry Pi OS
Bookworm for the Raspberry Pi 4 and 5. No checks have been
carried out with other/newer operating systems or hardware.

To make using the display with the Raspberry Pi particularly easy, we use
the luma.oled library. You can install the dependencies required for in-
stallation with the following commands:

sudo apt install git python3-dev python3-pip python3-numpy
libfreetype6-dev libjpeg-dev build-essential

sudo apt install 1libsdl2-dev 1libsdl2-image-dev 1libsdl2-mixer-
dev libsdl2-ttf-dev libportmidi-dev

Now activate the required interfaces by entering the following command:

sudo raspi-config

You can now activate SPI and 12C under 3 Interface Options so that you
can use both interfaces.

You must now create the virtual environment for this project. To do this,
enter the following commands:

mkdir your_project
cd your_project
python -m venv --system-site-packages env

source env/bin/activate

Now install the luma library with this command:

pip3 install --upgrade luma.oled
Download the sample files with the following command:

git clone https://github.com/rm-hull/luma.examples.git

Now enter the following commands for installation:

cd luma.examples

python3 setup.py install



SPI-Interface
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After you have connected the display, you can execute a sample programme with
the following two commands:

cd ~/your_project/luma.examples/examples/

python3 demo.py -i spi



12C-Interface

Wiring
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After you have connected the display, you can execute a sample pro-
gramme with the following two commands:

cd ~/your_project/luma.examples/examples/

python3 demo.py



5. ADDITIONAL INFORMATION

Our information and take-back obligations according to
the Electrical and Electronic Equipment Act

(ElektroG) ;@:

Symbol on electrical and electronic equipment:

This crossed-out dustbin means that electrical and electronic appliances
do not belong in the household waste. You must return the old appliances
to a collection point.

Before handing over waste batteries and accumulators that are not en-
closed by waste equipment must be separated from it.

Return options:

As an end user, you can return your old device (which essentially fulfils
the same function as the new device purchased from us) free of charge for
disposal when you purchase a new device.

Small appliances with no external dimensions greater than 25 cm can be
disposed of in normal household quantities independently of the pur-
chase of a new appliance.

Possibility of return at our company location during opening hours:
SIMAC Electronics GmbH, Pascalstr. 8, D-47506 Neukirchen-Vluyn, Germa-

ny

Possibility of return in your area:

We will send you a parcel stamp with which you can return the device to
us free of charge. Please contact us by email at Service@joy-it.net or by
telephone.

Information on packaging:
If you do not have suitable packaging material or do not wish to use your
own, please contact us and we will send you suitable packaging.

6. SUPPORT

If there are still any issues pending or problems arising after your purcha-
se, we will support you by e-mail, telephone and with our ticket support
system.

Email: service@joy-it.net

Ticket system: https://support.joy-it.net

Telephone: +49 (0)2845 9360-50 (Mon - Thur: 09:00 - 17:00 o‘clock CET,
Fri: 09:00 - 14:30 o‘clock CET)

For further information please visit our website:
www.joy-it.net

Published: 2024.03.20

www.joy-it.net
SIMAC Electronics GmbH

Pascalstr. 8, 47506 Neukirchen-Vluyn
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